Installing Exp Cli Error

Each time i run npm i -g exp i get same error as this

npm WARN react-redux@5.0.6 requires a peer of react@^0.14.0 || ^15.0.0-0 || ^16.0.0-0 but none is installed. You must install peer dependencies yourself.

npm ERR! sha512-ybLKof9FyVAhNY+hVyGVQF2Br65uyYfrkBNTdiyxfObiHdSn8zvrZ/B62a3E0bbnb6f9VSpcVSfvEJtPqG0wMg== integrity checksum failed when using sha512: wanted sha512-ybLKof9FyVAhNY+hVyGVQF2Br65uyYfrkBNTdiyxfObiHdSn8zvrZ/B62a3E0bbnb6f9VSpcVSfvEJtPqG0wMg== but got sha512-AT7bYoV46OmsUJlhq4nN/xQcXhN94EyxfUFF8NxuPAVZk9Z6HtHxKmge18MnI8Uyy4W9E1gagYE6NoaLitf5rg==. (18185846 bytes)

and i can’t run any exp commands and i need to detach the exp project how can i go about this

Hi! EINTEGRITY usually results when you have a limited network connection, although sometimes there are bugs in npm that cause this as well. What version of npm are you using?

My network seems okay and i tried it several times, i am using npm 5.2.1,
am still troubling with that. I am using windows10 PC

hey @phobs, I was having some issues with npm 5 before, I switched to 4.6.1 and it helped with some annoying errors (how to change npm version)

if that doesn’t work, here are some things you can try:
rm -rf node_modules/
rm package-lock.json
npm install or yarn install

npm cache clean --force

npm cache verify

let me know if any of these fix the problem!

1 Like

I have to downgrade the version of my npm, but it has affected some of my working files. Like my set ups for vuejs

i am current running node version 9.0.0 and npm version 5.3.0
i face the same error issue about and i was able to solve with the command below:

sudo npm install -g exp --unsafe-perm=true --allow-root

Then i run exp path to save my PATH variable
Hope this helps

1 Like