Installed unimodules and getting: Native module NativeUnimoduleProxy tried to override NativeModulesProxy

I have just installed the unimodles following these instructions:Installing react-native-unimodules - Expo Documentation
but when building my android version (ios runs perfectly) I get Native module NativeUnimoduleProxy tried to override NativeModulesProxy. If I comment out the List of uni modules in, I no longer get this error, but I also can not use expo-location, which I am assuming is because uni modules is still not correctly installed.

Any advice would be incredible.

hi there! you can run expo init and choose the ‘bare’ template and compare that with your project to double check that you are following the installation instructions correctly

Hey thanks for your response! So, I did infact build another project from scratch, just installed expo-location and the other required modules, and everything worked fine, it was when I installed all of my dependancies for my project that issues occured. So I did one by one, came to the conclusion that it must have been @unimodules/react-native-adapter: 6.3.5 or react-native-geolocation-service: 5.3.0-beta.1.

Installing all other dependancies but those was allowing it to build and I did not need the geolocation-service library anymore as I was using expo-location in the end.

My knowledge of how react-native works under the hood is rubbish so I wouldnt be able to suggest why this is happening. But regardless, my issue is resolved still and it may not of been an issue with expo after all :slight_smile: