infoPlist property not being set (iOS)

In Expo 46.0.0 managed flow, adding the following line in app.config.js expo.ios.infoPlist does not update the properties in the Info.plist file that gets generated.

NSAdvertisingAttributionReportEndpoint: ''

Setting other parameters, such as NSUserTrackingUsageDescription or NSPhotoLibraryUsageDescription does reflect in the generated Info.plist, hence, I fear that this list of properties is all of the Info.plist properties that are supported in the managed workflow. Could someone confirm whether this is the case, and if so, how it could be overcome (other than by ejecting)?



I tried adding the same property as such in an app.json:

"infoPlist": {
        "NSAdvertisingAttributionReportEndpoint": ""

and then I ran npx expo prebuild, which simulates the step on EAS Build that syncs the app.json config to the native project files, and this item showed up in the resulting info.plist file. Therefore, I think this should work with EAS Build. With any such configuration, you can simulate how EAS Build will sync it by running the prebuild command (just don’t check the native project files in so EAS Build knows to run its own prebuild each time).

Yes, you are correct, this turned out to be an issue on our end.
Thank you.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.