ImagePicker Permission Not Granted in Production

Please provide the following:

  1. SDK Version: 37
  2. Platforms(Android/iOS/web/all): Only tried Android


I’ve seen this problem around, but without much in the way of responses.

I’ve never had an issue with using the ImagePicker to get an image from the user’s gallery, but since upgrading to SDK 37 it keeps failing to find the granted permission as a stand alone app.

The permissions have been granted for CAMERA_ROLL as well as CAMERA, I’ve added the relevant access in app.json, I can log (using the Expo Client App) that the permissions have been granted, but as a stand alone it always thinks the permissions have NOT been granted for the CAMERA_ROLL and subsequently, wont work.

Actually, printing the CAMERA_ROLL permission in production reveals it to be undetermined when granted, and I can access the device’s gallery whether permission is granted or not… i didn’t think this would be allowed!?

I ran aapt d permissions [my app] on the app and the following permissions are found:

uses-permission: name=''
uses-permission: name=''
uses-permission: name='android.permission.ACCESS_NETWORK_STATE'
uses-permission: name='android.permission.INTERNET'
uses-permission: name='android.permission.SYSTEM_ALERT_WINDOW'
uses-permission: name='android.permission.WAKE_LOCK'
uses-permission: name='android.permission.ACCESS_COARSE_LOCATION'
uses-permission: name='android.permission.ACCESS_FINE_LOCATION'
uses-permission: name='android.permission.CAMERA'
uses-permission: name='android.permission.WRITE_EXTERNAL_STORAGE'
uses-permission: name='android.permission.READ_EXTERNAL_STORAGE'
uses-permission: name='android.permission.READ_INTERNAL_STORAGE'
uses-permission: name='host.exp.exponent.permission.C2D_MESSAGE'
uses-permission: name='android.permission.MODIFY_AUDIO_SETTINGS'
uses-permission: name='android.permission.ACCESS_WIFI_STATE'
uses-permission: name='android.permission.RECEIVE_BOOT_COMPLETED'
uses-permission: name='android.permission.REQUEST_INSTALL_PACKAGES'
uses-permission: name='android.permission.STORAGE'
uses-permission: name='android.permission.FOREGROUND_SERVICE'
uses-permission: name='android.permission.USE_BIOMETRIC'
uses-permission: name=''

…so it does seem the permissions are getting through, and they appear as granted in the Android system.

I really need to get this app published so any help would be very much appreciated.



I really need to release this app, any help from you Expo guys would be great.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.