ImagePicker.launchCameraAsync does not open in the full screen on iOS devises

Please provide the following:

  1. SDK Version: 41
  2. Platforms(Android/iOS/web/all): iOS
  3. Add the appropriate “Tag” based on what Expo library you have a question on.

After upgrading to SDK 41, the Camera view does not open to the full screen with ImagePicker.launchCameraAsync on iOS devices any more .
On iPad it opens in the center of the screen overlaying the screen it was opened from, which looks very weird.
on iPhone, it also looks like an overlay on top of the parent screen, and you can see the portion of the parent header.
Another indicator that it does not open to the full screen, it that there is a grey shaded area blow the 1x, 2x zoom indicator. If i drag the top portion (the one that has flash cam control) up, the grey area under the zoom indicator disappears (slides down). When I release the finder, everything snaps back to previous state as shown on the attachment photo. The gray area is blocking part of the photo view, which makes it harder to understand the boundaries of the photo being taken. It also gets in a way of the zoom control working properly – definitely something is not working the way it was intended.

It used to work correctly prior to the upgrade.
And it does work fine on Android.

Hey @dmitryame, can you share a public reproducible case of this? As well, can you let me know what iOS devices/versions you’ve tested and reproduced this on?

Cheers,
Adam

Hi @adamjnav
You cal clone public github GitHub - echowaves/WiSaw
It’s a managed expo workflow, so just do yarn; yarn start and scan the code to open it with Expo Go. The project does not require sign in – just click the photo button on the first screen and you’ll see.
This is the line where I launch the camera view WiSaw/index.js at 496399f05026e42a52bcf979ae92abd6ebb2074a · echowaves/WiSaw · GitHub
I tried it on iPhone 8 plus, with iOS 14.6.
I also tried it on iPad pro, and it does behave different but still not correct – it opens cam view in the middle of the screen as an overlay.

@adamjnav, any luck reproducing the issue? Let me know if I can be of any help.

Updated SDK to version 42 – still the same behavior.

Experiencing the same issue on every IOS device I’ve tested using Expo SDK: 41, 42. Interested in either finding some resources on modifying the launchCameraAsync Modal to fullscreen, or otherwise forcing the underlying UIIImagePickerController to use its default ‘fullscreen’ option. Any info is greatly appreciated!

Kind Regards,
S

Seems like a bug to me. Is expo team going to consider it as a bug? Any additional system this needs to be submitted?

Maybe it would be best to submit an issue to GitHub. If you can make a minimal app that reproduces the problem and add a link to it in the bug, that would be good.

Followed your advise @wodin , and filed a bug – thank you.

Had to create a barebones project for that, but that was good – the issue is definitely there, I was able to reproduce it in this barebones project.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.