i installed eas-cli but still getting error zsh command not found : eas macos

i installed eas using npm install --global eas-cli
but still getting zsh command not found : eas when i run eas build
on macos

Hi @anka.ahmad

This can happen if the global npm bin directory is not in your PATH.
Try running npm prefix -g to find the prefix. There should be a bin directory inside that. You should see an eas symlink there.

If you make sure that bin directory is in your PATH then it should work.

thanks you for your reply @wodin
i can see that i have a eas inside that folder and still not working
see screenshot below

OK, then you’ll need to add it to your HOME environment variable.

Open the Terminal
Run the following command, being very careful not to make a mistake:

echo 'export PATH="$(npm prefix -g)/bin:$PATH"' >> ~/.zshenv

Close the terminal and open it again
The eas command should work now. You can run eas --version to test that it shows which version of eas-cli is currently installed