i get a Not found page on auth.expo.io

Since few minutes when i’m trying to use my manual authentication flow via twitter api and i get a surprising Not found blank page rather than to be redirected to the twitter login page. Hopefully everything is okay on the standalone production version of my app (for now). But i need to make an important over-the-air update an i’m afraid that auth issues that i get on the development version will affect my production app.

I don’t know if the issue was caused by me or if it’s a general problem on expo.

Is someone has faced the same issue ?

2 Likes

Hey @mhacker,

Can you share some code related to what you’re talking about? I’m not quite sure I’m following what’s going on here.

Cheers,

Adam

Maybe related issue here.

I’m using AuthSession for authentication with my own OAuth server, but suddenly auth.expo.io returns “Not found” page.
Everything was OK few hours ago.

AuthSession.getRedirectUrl() returns https://auth.expo.io/UNVERIFIED-localipaddress-appslug

I’ve never seen this UNVERIFIED string.

Thanks

I’m facing exactly the same issue with using AuthSession for Facebook authentication. Looks like it is related to this commit https://github.com/expo/expo/blame/e46572c862475db506dbbfa683c905a9466fd881/android/expoview/src/main/java/host/exp/exponent/ExponentManifest.java#L519-L531 which adds a prefix of UNVERIFIED if the protocol is exp or http, which it is when testing locally.

Extra information: I am testing my app locally with the latest expo client. I am logged in with the expo client. I expected AuthSession.getRedirectUrl() to return https://auth.expo.io/@pritin.tyagaraj/slug-name but it returned https://auth.expo.io/UNVERIFIED-<LOCAL.IP.ADDRESS>-slug-name.

1 Like

Facing exact same issue from today. Did anyone find any temporary workaround?

1 Like

hi all, just to confirm, you are seeing this problem only when testing on an iOS device? I’m testing the redirectUrl on android and it is returning an url of @username/slug, which is the format we expect

@ragularuban @pritin.tyagaraj @mhacker @latica

Yes. I’m facing this problem on Expo app on a real iOS device.

I too confirm that I am seeing this issue with iOS (both on a real device, and with iOS simulator)

Checked in android. No problems. Only in IOS

Temporary Workaround
use expo start --tunnel

instead of expo start

1 Like

Hello, thanks for your info.
Unfortunately, it does not work for me both on a real device, and with iOS simulator.

Expo 30.0.0

Update:
It works for me, too.

I get bash: use: command not found on my Mac - is it something I should install?

But otherwise, I can confirm the above - the error is shown on iOS (on emulators, too), but my standalone app is not affected, thankfully.

However, I can’t login to the app, which means I can’t develop at the moment. Any timeline for a fix @quinlanj ?

I get same error too,

Its probably because of updated Expo Client which came when Expo SDK 30.0 released

Start the app with exp start --tunnel worked for me :slight_smile:

Also experiencing this error on iOS and Android devices. I’m already running with --tunnel, doesn’t fix it for me.

upgrading expo client to version 57.2.0 fixed the issue for me.

npm uninstall -g exp followed by expo start seems to be working for me :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.