I am getting a reanimated 2 and appregistry error in my terminal, what is the solution to this

My app seems to work fine when i run it on the web, however when i run it on android, using my android emulator, i get the following errors in both my emulator and the terminal.

This is the first time i am seeing this kind of error and i am a bit confused about the solution to this error

I am using the managed work flow.

I am not using eas-cli currently.

In your post, please share:

  • Whether you are bare or managed workflow
  • Your eas-cli version
  • What you have tried so far

Hey @captaineboy, what SDK version is your project? Also, have you checked to see if you configured Reanimated’s babel plugin like the error suggests?

@adamjnav I don’t really know the SDK version which my project is using, how do I check for that??

Also, how do I configure the Reanimated Babel Plugin?

I used expo drawer navigation commands to create the drawer navigation and it works fine both on web & the Expo Go App, however I am getting this error only in my Android Studio Android emulator

I am currently using Visual studio code as my editor