How to set Android certificate to Expo?

I built an android application using expo build:android and when I upload the app to Google Play Console it returns an error saying that the certificate is wrong.

I go to App Integrity in Google Play Console and I can see the keys (App signing key certificate):

MD5 certificate fingerprint: XXXXXX
SHA-1 certificate fingerprint: XXXXX
SHA-256 certificate fingerprint: XXXX

I run the expo fetch:android:hashes and the values are different. How can I update the keys on Expo or Google Play Console for the keys to match?


expo build:android gives you the option to override your existing credentials:

  Usage: build:android|ba [path] [options]

  Build and sign a standalone APK or App Bundle for the Google Play Store


    -c, --clear-credentials           Clear stored credentials.
    --release-channel <channel-name>  Pull from specified release channel. (default: default)
    --no-publish                      Disable automatic publishing before building.
    --no-wait                         Exit immediately after triggering build.
    --keystore-path <app.jks>         Path to your Keystore.
    --keystore-alias <alias>          Keystore Alias
    --generate-keystore               [deprecated] Generate Keystore if one does not exist
    --public-url <url>                The URL of an externally hosted manifest (for self-hosted apps)
    --skip-workflow-check             Skip warning about build service bare workflow limitations.
    -t --type <build>                 Type of build: [app-bundle|apk].
    --config [file]                   Specify a path to app.json or app.config.js
    -h, --help                        output usage information

Thank you. I believe the solution would be:

expo build:android keystore-path <app.jks> 

However, how can I download/create a Keystore from Google Play Console?

For that answer, you’d have to look in your Console and search Google’s docs, I’m not 100% sure

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.