How to produce .ipa file for detached app

As the title states I just detached my Expo app and loaded up on XCode as per documentation. I also published my app and I used that url in the EXShell.plist file and placed it in the manifestUrl key. For some reason I can’t click in the Archive button on XCode which I used in the past to build native iOS apps for uploading to iTunes connect. I was wondering how can I do this for detached Expo apps. As the documentation is not too clear on how to produce it.

Edited: Sorry my suggestion was incorrect, my bad @jamongkad

Hey Jimmy thanks, ummm I’m not too sure toying around with the Preprocessor Macros is a good idea. Is that standard practice for detached apps? If anything I my detached app to release which I believe should have solved the problem but it didn’t…

Yeah so I tried detaching again and same problem. Am I the only one who is running into this problem?

Hey there,

For some reason I can’t click in the Archive button on XCode

So this Archive button doesn’t work for you?


Can you make sure you are targeting the right device here?


You need the “build-only device” for Archive to work. (this is not specific to ExpoKit, we don’t do anything special with regards to your build configuration.)

I’m being stupid. You’re right, even as a native iOS developer I keep forgetting to do this. Thank you very much!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.