How to fix 'build:ios' error - you already have a current ios distribution certificate

I’m trying to build an expo app to replace an existing one.

When I run build:ios I get the following error:

Reason:You already have a current iOS Distribution certificate or a pending certificate request. Maximum number of certificates generated, raw:{"responseId":"a69b1080-c01e-47d3-9c9b-6a56979f079f","resultCode":7460,"resultString":"Maximum number of certificates generated","userString":"You already have a current iOS Distribution certificate or a pending certificate request.","creationTimestamp":"2018-01-18T10:03:33Z","protocolVersion":"QH65B2","userLocale":"en_US","requestUrl":"","httpCode":200}

I’ve tried revoking the push notification certificate and deleting the distribution certificate in the apple developer account, but I’m still seeing the same problem.
Is there something else I need to do?

You need to run latest version of exp and do exp build:ios -c after having cleared the certs apple developer account.

1 Like

Thanks Edgar! This is great, sorted my problem.
There were a few more certificates to get rid of than I realised.

What do you mean there were a few more certificates to get rid of? Did you delete all of them? Could this do anything to the current production version if you delete a certificate associated to it?

I’m running into the same problem and exp build:ios -c returns the same result :sob:

It means you have 2 dist certs already, you can interactively remove them with

exp build:ios --revoke-apple-dist-certs --revoke-apple-push-certs -c

or do it via the website at

as I want to update my app in appstore, using the command you mentioned will update it for the people that already have my app installed?
exp build:ios --revoke-apple-dist-certs --revoke-apple-push-certs -c

I am getting the multiple profiles found error

there was no need to do --revoke-apple-dist-certs --revoke-apple-push-certs -c at all, simply doing exp build:ios was enough, would reuse your existing creds and give you an IPA.

I have tried, but I got:

'Maximum number of certificates generated' or 'duplicate profiles'

then consider using the flags --revoke-apple-dist-certs, --revoke-apple-push-certs,
and --revoke-apple-provisioning-profile or go to
and revoke those credentials manually
[exp] Error while gathering & validating credentials
[exp] Reason:Multiple profiles found with the name 'com.xxxxxxAppStore'.  Please remove the duplicate profiles and try again. There were errors in the data supplied. Please correct and re-submit.,

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.