How to efficiently troubleshoot Expo

Please provide the following:

  1. SDK Version:
  2. Platforms(Android/iOS/web/all):

I’m getting the following error and I’m beyond frustrated. Expo doesn’t point towards the source of the error and I’ve been combing through all of my codes for the past hour to find this mysterious variable, “st”. I’m assuming this is some typo that I’ve made. I’ve commented out all of my screens, but still the same error. So I’ve combed through all of the query and mutation files, App.js, etc, but still no luck. I’ve even combed through the back end files to no avail. I’ve removed and re-installed my node modules, but still the same error. Is there a way to trace the source of this more efficiently? Or is this even a typo error or is this something else? Please help!!

I get the following instruction:

info PRO TIP When you see Red Box with stack trace, you can click
any stack frame to jump to the source file. The packager will launch
your editor of choice. It will first look at REACT_EDITOR
environment variable, then at EDITOR. To set it up, you can add
something like export REACT_EDITOR=atom to your ~/.bashrc or
~/.zshrc depending on which shell you use.

so I set up my vcode in bashrc as the REACT_EDITOR but clicking on the error doesn’t launch the editor to the source file.


Based on the screenshot it looks like the crash happens in AV.js (from expo-av) in the getNativeSourceAndFullInitialStatusForLoadAsync function.

What SDK version are you using? The line numbers in AV.js might not be the same on the master branch as they are in the branch for whichever SDK you’re using.

The rest of the stack trace makes it look like the error happens while loading the module, so possibly not related to any of your code.

I’d try killing expo start, then clearing caches (e.g. watchman watch-del-all, remove things related to React Native or Haste from $TMPDIR, maybe remove the .expo directory in your app’s root directory, make sure there are not Expo-related node processes still running.) Then run expo start -c and see if that sorts it out.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.