Hot Reloading -- Module HMRClient is not a registered callable module (calling enable)

09 AM

I have faced issues with Hot Reloading on my iOS emulator since the very beginning, but I never bothered to ask the community back then. These days, for some reason, my Live Reloading has become way too slow. I tried enabling Hot Reloading once again and the error is this. Is this a normal thing, and is there any workaround to this error? Any help is appreciated.

Cheers :slight_smile:

1 Like

Okay so apparently all I had to do was clone the repo once again. It’s working now. On both Android and iOS. :thinking:

1 Like

I am facing same error once again. I don’t know what happened. Can someone help me triage this?

hey @kashish, try restarting your packager or computer to see if that helps. Also ensure that your package.json and app.json are pointing to the same sdk

Hey @quinlanj thanks for the reply. I did all that (multiple times) and can assure that package.json and app.json point to the same sdk. Is there anything else I could do? :neutral_face:

hey, sorry there seems to be very vague answers online (as you probably found out)

have you tried deleting and reinstalling all your node_modules?

also can you paste your app.json and package.json

Hey, yeah the answers so far have been pretty vague. Guess what? We just upgraded to Expo SDK 23.0.0!
I am hoping the problem won’t recur now, because so far so good. And Hot Reloading works. If the problem recurs, I will let you all know for sure and we’ll look for a solution.


@samee @quinlanj

1 Like

My guess is you need to be in development mode for hot-reloading to work. I could be wrong! did you try that?


I was facing the same issue and I resolved it turning off the production mode in the expo CLI.