Hi I can't install Expo in my Mac


node ./postinstall.js

ngrok - error unpacking binary { Error: EACCES: permission denied, open ‘/Users/gcetzal/.npm-global/lib/node_modules/exp/node_modules/@expo/ngrok/bin/ngrok’
errno: -13,
code: ‘EACCES’,
syscall: ‘open’,
path: ‘/Users/gcetzal/.npm-global/lib/node_modules/exp/node_modules/@expo/ngrok/bin/ngrok’ }
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @expo/traveling-fastlane-linux@1.4.5 (node_modules/exp/node_modules/@expo/traveling-fastlane-linux):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for @expo/traveling-fastlane-linux@1.4.5: wanted {“os”:“win32,linux”,“arch”:“any”} (current: {“os”:“darwin”,“arch”:“x64”})

npm ERR! errno 1
npm ERR! @expo/ngrok@2.3.0 postinstall: node ./postinstall.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the @expo/ngrok@2.3.0 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /Users/gcetzal/.npm/_logs/2018-03-12T18_52_24_363Z-debug.log

How did you try to install Expo? How old is your Mac? What operating system are you running?

I’m trying install expo with
npm install -g exp, my mac is from 2017, I have highSierra

what version of npm are you using?

I’m using the version 5.7.1

I just install it on another mac and same issue

i just successfully installed with node 9.8.0 and npm 5.6.0

can you try with those? trying to isolate whether its an npm issue or not.

nothing, same issue :c

it might be some kind of permissions issue.
have you tried following this guide?

just searching for ideas here.

nothing, same mistake, should I use yarn?

Hey @geceba! We’ve changed the way this dependency is installed in exp v50.0.1. Could you try again with npm install -g exp, and let us know, if it works now?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.