Hi, expo build:ios not working, your build is unknow

Hello, we are encountering an error when compiling in .ipa. Anyone else has happened? We already make sure that the authentication is correct.

Now we are going to try to generate another build, with the same code, I will update the status of this test here.


we change the name of the build and it is not working either

see you later <3

Hi, I’m having the same issue for a few weeks now. Here is my open question:

Have you tried the command expo credentials:manager? What output you get?

I having the exact same problem sent email to the expo team but no reply yet. I run expo credentials:manager and dont see any errors. I can build android with no issues. This is only happening with IOS builds. Trying to find urgent help on this since have schedule launch this week.

Anyone here that can give us at least a hint of what this error means ?

hi! We still have no expo response and I have not found another solution either. completely blocked

They replied to me via email recommended to test latests CLI but had no luck. I replied to them again with details and pending new response.

@agarcia00 @miguel.s.itoeste - can you send emails to secure@expo.io with your build information?

This is most likely the same issue as this one from Github, which should be resolved by upgrading the most recent version of expo-cli. Even though that did not work for @agarcia00, I recommend trying that as it has worked for most people

@agarcia00 can you share the exact command you’re running? It seems your last successful build was on April 25th, has anything changed with your iOS credentials since then? and please share the output of expo diagnostics

Hello Charlie,

The command I tried based on the GitHub link is

expo build:ios --dist-p12-path ./certs/Certificates.p12 --push-id 8C72XL55U2 --push-p8-path ./certs/AuthKey_8C72XL55U2.p8 --provisioning-profile-path ./certs/productioncomtravelbirdsappprofile.mobileprovision --team-id 5J46V5X3JU --type archive

Regarding apple credentials they have not changed neither the certificates.

Here is the output of expo diagnostics command:

Expo CLI 3.20.3 environment info:
OS: macOS 10.15.4
Shell: 3.2.57 - /bin/bash
Node: 12.5.0 - ~/.nvm/versions/node/v12.5.0/bin/node
Yarn: 1.21.1 - ~/.nvm/versions/node/v12.5.0/bin/yarn
npm: 6.9.0 - ~/.nvm/versions/node/v12.5.0/bin/npm
Xcode: 11.3.1/11C504 - /usr/bin/xcodebuild
expo: ^37.0.0 => 37.0.7
react: 16.9.0 => 16.9.0
react-dom: 16.9.0 => 16.9.0
react-native: https://github.com/expo/react-native/archive/sdk-37.0.0.tar.gz => 0.61.4
react-native-web: ^0.11.7 => 0.11.7
react-navigation: ^4.0.10 => 4.2.2
expo-cli: 3.20.3

Is your push key being used by any apps at the moment? It might be worth clearing out the credentials we have stored for you for that app by passing the --clear-credentials flag (be aware that if you are using the push key in production, that would break push notifications for apps using the push key, so only do this if you are sure that is not the case)

Hello Charlie,

I did tried to clear creds but did not revoked the certs in the apple dev. Is what your asking to pretty much clear creds and also re-create certs ?

I think letting Expo handle cert generation would be best, so running just the command expo build:ios -c without passing in any credentials manually

Hello Charlie,

Did as you requested. Got the same results even if EXPO is the one setting up the certs. and without specifying the credentials manually on the command. :frowning:

sorry @agarcia00 :confused: I have tried to reproduce this on my end but haven’t had any luck so far. Could you try building a blank expo init project and seeing if that completes successfully for you?

Any verbose details about this error you can share. At least to understand why is ocurring besides "unknown"v? I will try to create new project and test.

It looks like we’re unable to find the push notification credentials that should be associated with that build, so the build errors

Thanks for the details tho thought since i selected EXPO to handle the certs it should have created that correctly :frowning: I will test creating a new project and provide feedback.


Im doing further tests so far i did noticed something that may be the issue.

I clear all the certs from my dev account and allow expo to build them all. I do see the cert and the provisioning profile get created and see them in apple dev account. But even tho expo says it created the push notification cert is not listed in my dev account at all.

Could this be the issue ?

Hello Charlie and Expo Team,

Here is a list what i tried so far need i think their a rare bug here but cent seem to identify.

  • Removed all. certs and keys from my apple dev account so they are all created by EXPO (FAIL)
  • Tried a quick empty project and that worked ← still dont understand what is so much difference.
  • I role back my code all the way to the date last time i was successful on creating an IOS build (FAIL)
  • No issues with android
  • I created a new APN manually as well just in case. (FAIL)

Hi, we have solved the mysterious error, we had misconfigured the Apple developers application, we corrected that and the compilation worked for us. did you try that