[help CRNA] trying to eject and detach from expo but having some issues , doubting if I'm doing it correctly?

I have used CRNA for my project now I need some native functionality .

  • don’t know whether to detach or eject .

since expo is gone how do I deal with code like the following

import { MapView, Location, Permissions, Constants } from "expo";
    FontAwesome: require('../../assets/fonts/FontAwesome.ttf'),
  MaterialIcons: require('../../assets/fonts/MaterialIcons.ttf'),
  Ionicons: require('../../assets/fonts/Ionicons.ttf'),
  EvilIcons: require('../../assets/fonts/EvilIcons.ttf'),

keep in mind that I tried to just detach and use expo kit but had the following error
github issue link

you can still use that stuff once you’ve ejected. it should still work. the expo sdk is still part of a detached/ejected app unless you rip it out.

how do I run the project ?

how do I get the native code ?

thanks .

if you ejected, then you should have a both an android project you can open with android studio and an ios project you can open with xcode. just open the android directory with android studio.

It took me so much time to completely eject the expo and make it runnable.
I faced multiple issues, one after other.

You run the below command
npm run eject
run the command to build for android
react-native run-android
You will get " A problem occurred configuring project ‘:app’. > SDK location not found " error
for this Create local.properties in the andoid project folder and give sdk path in that
Then you will face, exception as " com.android.ddmlib.InstallException: Failed to install all "
for this update gradle version in build.gradle
like this many more issues you may encounter. I have listed all the issues we face in this process and the solution which worked for me.

See the complete guide for ejecting Expo in this article