Hanging on "Downloading JavaScript bundle"

My app was working fine, but now hangs indefinitely in the iOS simulator, showing a spinning wheel and “Downloading JavaScript bundle.” (“Building JavaScript bundle” step works fine.) I’ve tried all three host settings in XDE, but to no avail. Also disabling my VPN does not change behavior.

XDE version 2.20.1

This happens to me too, on phone and simulator, some times it loads fine some times it gets stuck in the Downloading Javascript Bundle state.
It’s a brand new app too created with the expo xde.

I’m having this issue as well. Has anyone found a solution to this yet please?

For those having this problem, there is a solution that works here: Simulator slow to refresh

Same issue. Please help me if anybody has issue. Specifically this issue is coming for xcode 9 with ios 11 ( I have not checked with ios - 10 simulator)

Ok checked with that as well, not working.

I’d recommend a few things:

Sometimes the simulator itself can get into a bad state and not load content over the network (unrelated to Expo). Resetting Content and Settings may help.

Try using a localhost URL or LAN IP URL between the simulator and your computer. If you use the exp command line run “exp ios --localhost”. There is also a “–lan” flag.

Make sure you’re not using beta Xcode as we’ve had reports of problems in the past.

Hi there, I’m having this issue as well.

  • I have Xcode 9.0.1 (9A1004)
  • I have Simulator Version 10.0 (SimulatorApp-829.6 CoreSimulator-494.22.3)
  • I have Expo Version 2.21.0 (2.21.0)

I tried using LAN connection, localhost, and a lot of other options discussed here and on stackoverflow. Its just too slow to work with. Expo looks so great as a tool, it would be so great if someone could help me get over these 4-5 seconds loading time!



Ok, solved it.

For me, this had nothing to do with Expo. Apparently, “Chrome de-prioritizes Javascript running in any tabs not in the foreground”. Simulator apparently runs on chrome as well? Or maybe V8 is meant?

Anyway, the trick is to keep all chrome windows away in the window where the Simulator is running. May be obvious for people, wasn’t for me. Don’t know if this is also an issue with other browsers.

With help from this stackoverflow thread:

In the latest version of React Native expo, this bundle issue is resolved.