Google request Location permission


I’m trying to push my application to Google Store.
I’m using SDK 43 and EXPO-CLI 4.13.0

I don’t use any location packages but Google refuse my app because apparently I use one package which use that.

Issue with your app
Unclear feature description
We were unable to identify the feature that requires access to location in the background based on the declaration you submitted. Please resubmit a declaration with a clear description or additional information regarding the one feature that requires access to location in the background. Even if your app has multiple features that require access to location in the background, please only select one feature and resubmit your declaration form.

When I’m looking manifest, I see that expo install expo-localization and expo-location.
How can I remove all the packages using location ?

I try some solutions that I found but nothing work.

Thank you for your help !

EDIT : package.json

  "main": "node_modules/expo/AppEntry.js",
  "version": "2.1.18",
  "scripts": {
    "start": "APP_ENV=local expo start",
    "android": "expo start --android",
    "publish:staging": "APP_ENV=dev expo publish",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject",
    "build": "./script/",
    "update:patch": "standard-version --release-as patch",
    "update:minor": "standard-version --release-as minor",
    "update:major": "standard-version --release-as major"
  "dependencies": {
    "@react-native-async-storage/async-storage": "~1.15.0",
    "@react-native-community/datetimepicker": "3.5.2",
    "@react-native-community/masked-view": "0.1.10",
    "@react-native-community/picker": "1.6.6",
    "@react-navigation/bottom-tabs": "^5.11.11",
    "@react-navigation/drawer": "^5.12.5",
    "@react-navigation/native": "^5.9.4",
    "@react-navigation/stack": "^5.14.5",
    "@rematch/core": "^1.4.0",
    "@rematch/persist": "^1.1.6",
    "babel-plugin-module-resolver": "^4.1.0",
    "date-fns": "^2.22.1",
    "dotenv": "^10.0.0",
    "expo": "^43.0.0",
    "expo-camera": "~12.0.3",
    "expo-image-picker": "~11.0.3",
    "expo-notifications": "~0.13.3",
    "expo-status-bar": "~1.1.0",
    "formik": "^2.2.9",
    "immer": "^9.0.3",
    "react": "17.0.1",
    "react-dom": "17.0.1",
    "react-hook-form": "^6.4.1",
    "react-i18next": "^11.11.0",
    "react-native": "0.64.3",
    "react-native-gesture-handler": "~1.10.2",
    "react-native-mime-types": "^2.3.0",
    "react-native-reanimated": "~2.2.0",
    "react-native-safe-area-context": "3.3.2",
    "react-native-screens": "~3.8.0",
    "react-native-svg": "12.1.1",
    "react-native-swipe-gestures": "^1.0.5",
    "react-native-web": "0.17.1",
    "react-navigation-stack": "^2.10.4",
    "react-query": "^2.21.0",
    "react-redux": "^7.2.1",
    "standard-version": "^9.0.0",
    "standard-version-expo": "^1.0.3",
    "turtle-cli": "^0.20.7",
    "use-immer": "^0.6.0",
    "yup": "^0.32.9"
  "devDependencies": {
    "@babel/core": "^7.12.9",
    "@types/react": "~17.0.21",
    "@types/react-native": "~0.64.12",
    "@types/react-redux": "^7.1.9",
    "i18next": "^20.3.2",
    "typescript": "~4.3.5"
  "private": true

But expo-localization is something different.

What have you tried so far?
Which packages are you actually using?



Thank for your reply !
expo-location is also installed.

I try to add in my app.json an array for permissions with only CAMERA.
I also remove from package-lock.json the packages installed by expo that I don’t use.

I reproduce every step from : Android app rejected because of background location · Issue #11918 · expo/expo · GitHub

Nothing work…

But if expo-location is installed you need it also in your permissions. If you have installed expo-location yourself? So you need it for your app?

That’s the problem!
I never added this package in my package.json since I don’t need the LOCATION.
It seems that expo adds it independently of my will during the process of building.

Well that would sound strange.
Can you maybe post your package.json dependencies? Or anything that could help?

You’ll find the package.json in my edit post.
Thank for your help !

Have a look at Remove the request for location permissions from your app - #45 by lastof
Maybe this helps: They had the same issue and tried to remove the location permission from the app

Let me know if you were successful or not

1 Like

Hey @sk92, how are you building your app via expo build or eas build? If you’re still using expo build, please migrate over to EAS. You can read how it addresses this problem here. We have a migration guide as well.

1 Like


I try what you send me but it doesn’t work…

Hello ! Thank you for your reply !
Actually I use expo build but I’m gonna migrate to eas, I hope it’ll work ahah.

1 Like

Did you try the stuff from the link I posted?

this post is really helpful for me thank you for sharing with us

With eas we don’t have location package anymore so it should be good now.
Thank you for your help !

thank you for sharing with us..


If you use expo instead of eas, you should try eas, that’s fix my issue.
If you already use eas, I cannot help you… Did you set the permission array ?

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.