Google Play Store Sign and Expo Sign


Please need your help, im crazy with my Apps and the Google Play. I made an initial mistake and it was not paying attention to the issue of signatures. I have done everything that should not have been done, so I am exhausted and require a hand I have really tried everything and I have not managed to do anything!
The first time, The steps I have taken are:

expo build:android -t app-bundle --clear-credentials
select the first option, the bundle is generated and upload fine to the Google Play Store

Next, im update my app and run again (My BIG WRONG):
expo build:android -t app-bundle --clear-credentials

Since then I have not been able to upload an update of my app to the play store, it always gives me an error in the signature.

I really require your help to understand the subject thoroughly and look at the steps to follow. I saw that one can download some signatures from the GooglePlayStore to sign these files also try but nothing!

So I have two options:

  1. Try to be able to sign that new version that I know is possible but I have not understood how with the signature that one downloads from googleplay
  2. Do everything from 0, upload my app again but this time I want to know the real steps to have a backup of the signature with which I am “signing” and thus not fall into this error again

Thank you very much in advance to whoever takes the time to help me on this matter.


You will need to contact play store support to reset your keystore and send them .pem file generated by command expo fetch:android:upload-cert (this is public key for keystore currently on our servers). After they reset it, credentials currently on expo servers will work.

To backup keystore locally you will need to run expo fetch:android:keystore, remember that you need to have jks file plus 3 values that are printed on a terminal (keystore password, alias, alias password)

Try to be able to sign that new version that I know is possible but I have not understood how with the signature that one download from google play

You can’t recover old credentials, google play has only public key, it can be used only to verify the signature. To sign the file you would need private key that was stored inside keystore on our servers

Thanks for answer!!!.

Have the next questions:

  1. Ok i’m get the PEM file, i’m need use one pem file for any app or can generate one pem file to any app ( in the same google account)
  2. If have the pem file how can upload again this Pem file to expo? Or how can sign my app to this pem file?

Thanks for all

Please read carefully my previous answer.

Keystore contains public and private key, and when you run expo build:android keystore on expo servers is used to sign your application. PEM file is just public key, google needs that to verify the signature(you can’t use it to create signature)

You can share the same keystore(not pem file) between apps, but it’s a bad idea.

you need pem file only to send it google support, after that you can remove it. Keystore is important not pem file.

@wkozyra thanks!

One old question about this:

Im run:
expo fetch:android:keystore
expo fetch:android:keystore

And send the PEM file to Google.

Now when need generate a new version of my app to upload in Google Store, run:

expo build:android -t app-bundle

And no more, ready?

Pda: Im know need wait while Google upload my new PEM file

expo fetch:android:keystore is to download keystore
expo fetch:android:upload-cert is to create PEM file

after google support will reset your keystore you should be able to upload apk/aab normally. All info should be in response they will send, it’s possible that you will need to wait few hours or a day.

I have an EXPO app and I already created and published it on Google Play Store. The Google App Signing is activated for this project. Now I want to update this APK in this project. I used the command ‘expo build:android’ to build the updated APK.

Thanks to all.

The problem is solved.

Im clear all certificates and generate news. Next, upload the PEM file to google, and all my apps working

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.