Google map is not loaded on standalone Android only (likely a API credential issue?)

Maps are not loaded on standalone Android only. It works on iOS (in form of Apple map) and Expo client app as container (both Android and iOS). I am using Expo SDK 36.

I have been stuck with this problem and feel clueless how to debug. I don’t have much knowledge on all the details so I have spent a week without progress. I really appreciate your help!

By reading other posts, this seems to be a problem with the Google API credentials. I have activated/enabled “Maps SDK for Android” in my project in Google Developer Console and I have also created API Key. I have followed the respective instruction where I set the Application restriction to “Android apps” and entered the package name and SHA-1 certificate. For the SHA-1 Certificate I added the one from Google Play Console (under my app name>Setup>App signing>App signing key certificate) as well as the one from running expo fetch:android:hashes

One issue I have here is that I have 3 different projects in my Google Developer Console and I am not sure actually which one is the relevant one (is there any way how to figure this question?). So I have repeated the above steps for enabling Maps SDK and creating the credentials for all of three projects. Then I tried with all three API Keys in my app.json file and rebuild for Android and uploading the apk file in the device, but it still seems not working. (well, earlier I only did a expo publish which was faster process but then I read that might not be effective against changing the android.config.googleMaps.apiKey so I did expo build which is longer, in both cases in no avail. But I wondered what the correct way of testing would be)

Another point; when I run the following command to print out the signer on a generated .apk file, the Owner and Issuer have a different package name than my current package name. This is because the package name was changed a while ago. Could this be the cause of the problem?
keytool -printcert -jarfile myBuild.apk

I know my description is somewhat messy, but I so much appreciate it if you can give me hint on narrow down the problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.