Github Action building throwing error about "owner" not being set even though it definitely is

We are using:

  • Managed workflow
  • eas-cli version: 3.12.1

Error Description:

When my github actions run:

eas build --profile development --platform android --non-interactive

I get this error:

✔ Generated eas.json
EAS project not configured.
The "owner" manifest property is required when using robot users. See:
Error: build command failed.
Error: Process completed with exit code 1.

What I tried so far:

  1. I tried running this same command locally and it works fine. The error only occurs in the gh action.
  2. I followed the steps in the following link to set up the github action: Triggering builds from CI - Expo Documentation.
  3. I have triple checked that the owner is indeed set in app.json.
  4. I tried running it without --profile development just in case that could be it but the error persisted.
  5. Changing “owner” name from “org” to “@org
  6. Replacing app.json with equivalent app.config.js
  7. Replacing the “owner” from the organization name to my personal account’s name
  8. Changing the name of the access token from the EAS Dashboard from GitHub App · @org · ID:XYZ to org and to @org