gesture-handler simultaneousHandlers stopped working in latest Expo Go

With the latest Expo Go for iOS (, it seems to no longer be possible to use simultaneousHandlers. At first I thought this broke with Expo v44, after I upgraded, but after downgrading to 43 it still doesn’t work. I tested an online gesture handler demo in Expo Go, and it also doesn’t support simultaneous handlers with this client. I’ve tried different versions of react-native-gesture-handler and react-native-reanimated, but the problem persists.

In searching for solutions, I found that a patch to Go exists that makes a possibly relevant change ([dev-menu] Update apollo client & fix `undefined is not a function` · expo/expo@d1e350d · GitHub). Perhaps the change from setImmediate to setTimeout(0) is needed because of some other change in order to pick up the forward-declared handler refs?

It seems Go clients are created only very rarely, so I assume the wait could be very long.

I tried to build the client locally, but I don’t know what steps are necessary.

I don’t know if EAS builds use the same branch as the Go release or if it’s more recent or even at HEAD, but I tried to build my own client using EAS. However, this doesn’t work for me because I get a pod ENOENT error during builds, to which I’ve also found no solution (controlling the pod version didn’t help).

Any tips would be appreciated.