Genymotion is not responding. Error

Hello everyone

I am using Windows 10 and I am trying to use Genymotion emulator for my Android projects and I set the path to Android sdk in ADB but the error I am getting in Expo XDE is the following:

Couldn't start project on Android: could not install *smartsocket* listener: cannot bind to 127.0.0.1:5037: Only one usage of each socket address (protocol/network address/port) is normally permitted. (10048) could not read ok from ADB Server * failed to start daemon * error: cannot connect to daemon

Any comment?

Can you send a screenshot of your genymotion config?

Hi @jesse
Are you talking about this:


??

Yeah, that looks correct. Does running adb devices from a shell work?

I have never tried running from a shell.
I run it using GUI, like this:

And, it works perfectly well for Android debugging when I am using Android Studio.

Sure, my point is that if you aren’t able to run adb devices from a shell then XDE won’t be able to run adb either.

Same problem as you; until now I have not found any solution

Please share if you find one.

Ok sure, you too …

1 Like

Just to let you guys know, I had the same error.

Problem was, that I didn’t set the exp path like described in the Expo Docs here.

After following the steps, the error should be gone.

1 Like

still not working :cold_sweat:
It would be great, if someone could provide some documentation to set up genymotion/android studio with expo on windows. most guides out there seem to specifically target IOS.
help. :pray:

Can you tell us what you tried till now? It’s hard to figure out what is wrong without any information about your setup.

Kind Regards,
Mariano Weber

So this is what I have done,(windows)
installed Expo XDE.
installed Android Studio
installed Genymotion
changed Genymotions settings to “Use custom Android SDK tools” (found successfully)
created a blank project on Expo XDE
device - Open on Android

And the log throws this:
"Couldn’t start project on Android: could not install smartsocket listener: cannot bind to 127.0.0.1:5037: Only one usage of each socket address (protocol/network address/port) is normally permitted. (10048)
could not read ok from ADB Server

  • failed to start daemon *
    error: cannot connect to daemon"

running adb devices
returns

List of devices attached
192.168.206.101:5555    device

Just to get this right, you set the exp path like described here in Step 2, right? This fixxed it for me, got the exact same error as you and had the device listed correctly under adb devices.
I think the problem was although Genymotion had the right Android SDK, Expo didn’t, because I didn’t set the path. Please try this and share your result.

I am also stuck with the same issue. I have tried all possible steps including the one which @marianoweber has suggessted. But still stuck at the same place!

Did you add the android sdk path to your path variable before running exp path?

Yes. I have added. This is the issue which i am facing. Earlier i thought it is because of the absense of vt-x, which is not available in my system. I was unable to add android devices above 5.0. I am only able to add devices below 4.2.2. My genymotion virtual serverbox issue is sorted out. But with this, i am getting stuck in the last step.

Hey guys. Hopefully I can help out. This is pretty straight forward once you know what to do.

20,000 foot view… Expo needs to know where to run the Android adb tool and it can only know via the operating systems Environment Variables.

There is NO NEED to install the anything from Google. Set up correctly everything works with only Expo and Genymotion.


First, figure out where Genymotion installs it’s version of the Android adb.exe tool.
For me, on Windows 10 64-bit, it’s C:\Program Files\Genymobile\Genymotion\tools


It’s kind pain to set the Environment Variables via command line, so we’ll do it in the GUI.

  1. Close XDE, Expo CLI, and any other open command line terminals. They only pick up changes to Environment Variables upon opening.

  2. Open your Start menu and type environment. You should see a quick link to the system environment variables. Open it.

  3. Click the Environment Variables... button.

  4. Select the Path variable in your user variables sections and click Edit.

  5. Click New

  6. Add the path to the Android adb.exe tool installed by Genymotion.

  7. Click OK, OK, OK to close all the way out and save.

  8. Start up the Genymotion virtual device.

  9. Start up the Expo XDE and open a project.

  10. Click Device > Open on Android

  11. Expo for Android will download, install on the device, and open!

15 Likes

http://hathaway.cc/post/69201163472/how-to-edit-your-path-environment-variables-on-mac

Will it be useful for mac users?

1 Like

Thanks for your answer it solved the problem I was having!

1 Like