Gateway timeout when uploading credentials

When I try to upload iOS credentials to EAS using eas credentials, I get this error:

[Network] Gateway Time-out

I get the same error when I use eas build to make an iOS build.

When I try to upload credentials using the Credentials web page, I get a “Load failed” error, which I am guessing is the same issue.

This has been happening for at least a week, so this is not a temporary situation.

(Fortunately I can work around the issue by using local credentials via a credentials.json file.)

Actually I was not able to build using local credentials if iCloud was enabled, because the build did not contain the correct iCloud entitlement. Disabling it fixed the issue, but this is obviously not a long term solution.

More details about build issues: When I use eas build to make an ad hoc iOS build, I get the same error right after the profile is updated; i.e. the build is failing trying to upload the profile. This prevents me from making a staging build using remote credentials.