From August 2020, new apps must target at least Android 10

Please provide the following:

  1. SDK Version: 38.0.8
  2. Platforms(Android/iOS/web/all): androind, iOS

So I just built my app and uploaded it to the play store, then got From August 2020, new apps must target at least Android 10.

  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "eject": "expo eject",
    "build": "expo build:android --no-publish --no-wait --release-channel default",
    "build-ios": "expo build:ios -t archive --no-publish --no-wait --release-channel=default --team-id=W6YRS469GF --provisioning-profile-path beamx.mobileprovision",
    "upload-ios": "expo upload:ios --latest",
    "publish": "expo publish -q -c --release-channel=default",
    "postinstall2": "rm -rf ./node_modules/expo/node_modules/expo-font/"
  "dependencies": {
    "@expo/vector-icons": "^10.2.0",
    "@react-native-community/async-storage": "~1.11.0",
    "@react-native-community/clipboard": "^1.2.3",
    "@react-native-community/masked-view": "^0.1.10",
    "@react-native-community/picker": "^1.6.0",
    "@react-navigation/drawer": "^5.8.4",
    "@react-navigation/native": "^5.6.1",
    "@react-navigation/stack": "^5.6.2",
    "@twotalltotems/react-native-otp-input": "^1.3.7",
    "axios": "^0.19.2",
    "card-validator": "^7.0.1",
    "country-code-info": "^0.3.0",
    "expo": "^38.0.8",
    "expo-asset": "~8.1.7",
    "expo-cellular": "~2.2.1",
    "expo-constants": "~9.1.1",
    "expo-facebook": "~8.2.1",
    "expo-firebase-recaptcha": "^1.1.3",
    "expo-font": "~8.2.1",
    "expo-google-app-auth": "^8.1.2",
    "expo-image-picker": "~8.3.0",
    "expo-linear-gradient": "~8.2.1",
    "expo-linking": "^1.0.3",
    "expo-location": "~8.3.0",
    "expo-permissions": "~9.0.1",
    "expo-screen-orientation": "~1.1.1",
    "expo-task-manager": "~8.4.0",
    "expo-updates": "~0.2.11",
    "firebase": "^7.16.1",
    "humanize-duration": "^3.23.1",
    "libphonenumber-js": "^1.7.55",
    "lottie-react-native": "^3.4.0",
    "luxon": "^1.24.1",
    "prop-types": "^15.7.2",
    "react": "16.11.0",
    "react-native": "0.62.2",
    "react-native-country-picker-modal": "^1.11.0",
    "react-native-dotenv": "^0.2.0",
    "react-native-flash-message": "^0.1.15",
    "react-native-gesture-handler": "~1.6.1",
    "react-native-google-autocomplete": "^0.1.9",
    "react-native-image-progress": "^1.1.1",
    "react-native-lightbox": "^0.8.1",
    "react-native-maps": "0.27.1",
    "react-native-maps-directions": "^1.8.0",
    "react-native-masked-text": "^1.13.0",
    "react-native-modal": "^11.5.6",
    "react-native-paper": "^4.0.1",
    "react-native-picker-select": "^7.0.0",
    "react-native-reanimated": "~1.9.0",
    "react-native-responsive-screen": "^1.4.1",
    "react-native-safe-area-context": "~3.0.7",
    "react-native-screens": "~2.9.0",
    "react-native-tab-view": "^2.15.0",
    "react-native-unimodules": "~0.10.1",
    "react-native-webview": "9.4.0",
    "reanimated-bottom-sheet": "^1.0.0-alpha.20",
    "": "^2.3.0",
    "styled-components": "^5.1.1"
  "devDependencies": {
    "babel-preset-expo": "^8.2.3"
  "private": true

Not sure if I’m missing something?


Same problem, but we use Expo 37 for now.

Android documentation: Create and set up your app - Play Console Help

I’m dealing with this too. It didn’t work for me in Expo 37 so I upgraded Expo and cli to the latest and I’m still getting the warning when I upload the app bundle to the play store. If I don’t see a solution soon I might expo init a new project and copy all my code over to see if it builds with a later target API. If all else fails I guess I can eject and set the target manually.

I have the same problem

Someone solution for this problem? Thanks!

This needs to be solved in the expo build service, not the SDK. You can’t fix this by upgrading the SDK.

Edit: Since I keep getting private messages about this, here is the same response as I posted on Slack:

  • it’s a build service update, you can’t fix it by upgrading the sdk
  • it’s unlikely they (Goolge) turn you away from August first (Google only started showing this message this week ).
  • they’re (Expo) probably aware but have not communicated it.

Scott also said:

Based on past situations like this, it’s sometimes the case that it’ll still allow the lower SDK version until the end of August (as opposed to the first day of August), and that it’ll be a builder change which will simply require a rebuild of affected apps once implemented.

1 Like

The Expo team is busy with this issue here:

1 Like

Thanks! I’ll redirect anyone to that issue :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.