Fresh install of Expo and XCode, and I'm getting an error opening iOS Simulator

Please provide the following:

  1. SDK Version: ~42.0.1
  2. Platforms(Android/iOS/web/all): iOS
  3. Add the appropriate “Tag” based on what Expo library you have a question on.

I’ve just done a fresh install of the expo-cli, and a fresh install of XCode on my M1 Macbook pro, and when I start the iOS simulator, I get this JavaScript bundle error.

Failed building JavaScript bundle.
node_modules/@react-navigation/core/src/CurrentRenderContext.tsx: Property body[6] of BlockStatement expected node to be of a type ["Statement"] but instead got "AssignmentExpression"

I didn’t make any changes to the code, just a ran these commands:

$ expo-cli init MyApp
$ cd MyApp
$ yarn start
$ i (<- to run the iOS simulator)

I did try opening it in web, and it was fine. So this seems to just be an issue with iOS simulator. (I haven’t tried Android yet). Not sure what I did wrong, and I can’t find any solutions to this error online. Any help would be much appreciated!

Cheers,
Chris

1 Like

Windows 10 here! I am getting the same error when running a fresh project on my android device!

I tweeted them and they responded within seconds.

link to the upstream repo

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.