Fonts not working on production iOS app.

Please provide the following:

  1. SDK Version: 37
  2. Platforms(Android/iOS/web/all): Android / iOS
    I have application with custom fonts loaded for it by @use-expo/font hook.
  const [ready] = useFonts({
    'Muli': require('./assets/fonts/Muli-VariableFont_wght.ttf'),
    'Muli-Black': require('./assets/fonts/static/Muli-Black.ttf'),

Fonts are working in dev environment on all devices. But are working on production only for Android. On iOS fonts fails to load.

Links to my app:

Hey @tomasz-szarek,

Given that this is a standalone issue it gets a bit harder to debug. Have you by chance tried using a different custom font to eliminate the possibility of it being an issue with the Muli font specifically?

Would also be curious to know if this occurred on previous SDK versions or if it got introduced when your app ran on SDK 37.


Hello @adamjnav

My App was released to production on SDK 37 so I have no compare with previous SDK versions. I haven’t tried other fonts but it seems to be not problem since this font is working on development enviroment. Just production fails.

I have found that presence of ios and android folders (I had some leftovers folders after attempt to eject) can be cause I will update if this is correct.

1 Like


Removing android and ios folders fixed problem for a while but after second release on the same release channel it’s broken again. I think something is broken when we make update of app because on very first version fonts were working ok.

1 Like

I’m facing the same issue, though my app is not ejected. Fonts are loaded correctly on expo app while development, also for production android fonts are seen correctly, however for iOS ipa files fonts are not seen. I’m using expo SDK 37.0.0 and it’s been 3 days I’m trying to debug this problem with no luck :slightly_frowning_face:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.