Fetch to IP address giving 'Network request failed' in the simulator

Hey everyone, I’m working on an app which integrates with Phillips Hue lighting. This works by accessing the API using the IP address of the Philips Hue bridge which is connected to the wifi router.

A GET request to the endpoint works via postman, but when ran in expo (ios simulator), it throws an error ‘[TypeError: Network request failed]’. The endpoint is as follows:

From my research I think it is due to how the simulator runs, using it’s own ip address. Is it because the simulator is running on its own local network and so the bridge that I’m trying to connect to using the IP address, doesn’t exist there? I’m assuming that I haven’t got that quite right, but nevertheless, I’m still not sure how I can solve this. Does anyone know what I’d need to do to be able to access the IP address of my bridge?

Thanks in advance!

One way I was able to get this to work was to use Ngrok to forward the request to the ip address of the hue bridge. So from my macbook, I ran:
ngrok http https://<bridge ip address>

Which gave me a URL I can access which forwards the requests to my bridge ip address:

https://<some id>.eu.ngrok.io -> https://<bridge ip address>:443

Is this the recommended approach? Or is there a better way to do this?