Features Preview Expo run:ios

SDK Version: 42
Platforms: IOS

I installed a fresh expo project, I installed the expo-Dev-client package. Now I’m trying to run expo run:IOS command it takes some minutes and finally I get this error “failed to build ios project. xcode build exited with error code 65”
Before that error I had this error “overriding instance method must be as accessible as the declaration it overrides”.
Somebody can help me…?!

There is probably another error in the logs that points to the actual issue in your project. You should search that error or post the actual error message here, otherwise it’s pretty difficult to try and say what the issue could be

Unable to find a specification for ‘expo-dev-launcher’ dépend upon by ‘expo-dev-client’

When I’m trying to run ‘expo run:ios’ command

Hm, we should be installing that as a dependency if it’s necessary. Can you try running expo install expo-dev-launcher and rerunning the build?

expo init a plain managed project, followed by

  • yarn add expo-dev-client
  • expo run:ios

succeeded for me, you may want upgrade expo-cli

Thank you for the feedback, I’ll try

I installed ‘expo/metro-config’ but the issue persist

Can you try the steps I mentioned above? Better to test on a blank project

Okay thank you. Can you explain me the issue…?

I did it everything work fine thank you.

1 Like

awesome! glad to hear it

Hello sir, since the last build, I worked on the ios simulator so today I try to test it on my iPhone, I have this problem.
I run ‘expo start - - dev-client’