Failed to resize image: AppIcon20x20@3x.png

HI there, just upgraded from expo 27 to 31 and done all the various things to upgrade, when I try and build the app I’m getting an error - Failed to resize image: AppIcon20x20@3x.png. (see below) - does anyone know what’s wrong? The app.json is below…

“expo”: {
“name”: “xxxxxxxxxxxx”,
“icon”: “./content/AppIcon1024x1024.png”,
“version”: “1.2”,
“slug”: “xxxxxxxxxxxx”,
“orientation”: “portrait”,
“splash”: {
“image”: “./content/loading.png”,
“backgroundColor”: “#000000
“ios”: {
“bundleIdentifier”: “xxxxxxxxxxx”,
“buildNumber”: “1.2”,
“isTabletOnly”: false,
“supportsTablet”: false
“android”: {
“package”: “xxxxxxxxx”,
“versionCode”: 4
“sdkVersion”: “31.0.0”

Modifying NSBundle configuration at /private/tmp/turtle/67d9da87-ce58-4bad-9bec-44f1070af1eb/archive/Release/ExpoKitApp.xcarchive/Products/Applications/…
Using standalone config: { isShell: true,
manifestUrl: ‘’,
releaseChannel: ‘default’,
testEnvironment: ‘none’ }
Configuring iOS Launch Screen…
Bundling assets…
Compiling resources…
Cleaning up iOS…
Error: Failed to resize image: AppIcon20x20@3x.png. (Error: Input file is missing or of an unsupported image format)
at /usr/local/turtle-js/node_modules/xdl/build/detach/IosIcons.js:104:21
at Generator.throw ()
at step (/usr/local/turtle-js/node_modules/xdl/build/detach/IosIcons.js:173:191)
at /usr/local/turtle-js/node_modules/xdl/build/detach/IosIcons.js:173:402

Hey @teamholmes,

What version of the expo-cli are you running?



v 2.6.14
Does that help?
Im building using the command
expo build:ios

Hi Teamholmes,

I am also having this same issue. Tried many steps and approaches suggested and nothing worked.

Do you have any solution found for this problem?



Hello @teamholmes @gnanajo,

make sure you have

    "assetBundlePatterns": [

in your app.json. Without this, assets are not uploaded and there is nothing to resize, so the error message is true - “Error: Input file is missing”. It’s not an Expo bug.

This produces the following error

Cannot read property 'forEach' of undefined

Hey @thenumber_tech,

A fellow user encounter that issue and said it had to with their config. Expo Build iOS - Asset Update and Image resize issue



You installed react-native from npm, Expo requires you to use our release of react-native.

1 Like

@dsokal Yes that indeed was it thank you!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.