Failed to read key from store

On my work account whenever I try to build application I get this error message Failed to read key <key>= from store "/tmp/turtle/keystore.jks": Cannot recover key.

I have keystore file with keystore password, alias and alias key (I’ve used expo:fetch:android:keystore to get those). It worked at monday and tuesday but all the suddens it stopped working today morning. I tried to import it usign keytool but all the suddens my alias key is not correct. I’ve tried many solutions and approches and from my perspective it looks like alias is correct, keystore password is correct but alias password is not. Is there any way to recover alias password or mayby someone has any idea how to debug this? I will appreciate any help

Hey @mperlakio,

Were you able to do this successfully since you posted? Unfortunately we’ve had some minor server issues recently so it may have been unfortunate timing. If not, we can discuss further.


Hey @adamjnav,

I’ve tried to build APK without expo to just find root of the problem. I’ve tried to use expo generated keystore but still with no luck. Whenever I try to pull my keystores I get my actual keystore (It matches with backup keystore), expo also returns me alias, keystore password and private certificate password. I’ve tried to import keystore with keytool and apparently alias is OK, keystore password is OK, but private certificate password is not. I’ve tried to upload on expo my backup keystore but result was the same.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.