failed to determine Android project configuration

If I run eas build I get this random error that I have no idea how to solve, please help:

⚠️  Cannot resolve the path to "eas-cli" package.


FAILURE: Build failed with an exception.


* Where:


Script '/home/expo/workingdir/build/node_modules/@react-native-community/cli-platform-android/native_modules.gradle' line: 456


* What went wrong:


A problem occurred evaluating script.


> React Native CLI failed to determine Android project configuration. This is likely due to misconfiguration. Config output:


[root:/home/expo/workingdir/build/android, reactNativePath:/home/expo/workingdir/build/node_modules/react-native, dependencies:[:], commands:[], healthChecks:[], platforms:[:], project:[:]]

link: Build Details — 03ecf9f9-8781-4382-b467-371f03125acc — lbnapp_new — Expo

hi there! it looks like your project won’t build locally. this is a bare project, so you should make sure you’re able to run npx expo run:android --variant release locally. see this guide for some help with troubleshooting: Troubleshooting build errors and crashes - Expo Documentation

try running npx react-native config in your project. my guess is that you will see that same error. you may also want to look into your react-native.config.js file

thanks for the quick reply,
npx react-native config did not create any errors
However, running
npx expo run:android --variant release

throws the error
FAILURE: Build failed with an exception.

  • What went wrong:
    Could not open settings generic class cache for settings file '/Users/arnavchowdhry/lbnapp_new/android/android/settings.gradle.

After searching around for an hour, I still have no idea how to fix this. Any suggestions?