Fail Signed Standalone app Android

Hi everyone!

Could someone help me?

I am using to develop my app and it is finished. I started the build process for Android with a keystore that already exists from other apps that I have. After the process was finished, I receive a link with signed app to download. After downloaded the app, I send to my Play Store but I always receive the message that: "The app is not signed"
What I’m doing wrong?

1 Like

Hey I just talked to you on Facebook! I’m going to try to upload one of my apps to the Play Store to see if I can reproduce the problem. Will let you know once I’ve done that.

Ok I tried this on one of my apps and it worked fine. How did you generate the keystore?

It might be easiest to debug this by running the same commands we run locally. You can see what we run starting here:

Hey Jesse! Thank you!

Well, I already have a signature.jks from another apk published. When I started the first build, expo cli prompt me for signature and I set the path for this file. After that, it prompted me to fill alias, password and etc. Then the build started normally.
After all this process, I downloaded the apk from the URL provided and when I try to upload to Play Store, gives me the error: “App not signed”

Yeah I understand - sorry that happened. Can you try running the commands here on one of your own unsigned APKs to see if you can reproduce the problem there? Those are the exact commands we run on the build servers.

Hi @jesse,

I could not run the commands. Could you help me how to run ?

Another question: Is there a way to resign this app?

Thank you!

Hm I’m not really sure what you mean. What are the commands you tried to run and what was the output?