Facebook Login does not work in 3.11.1

After updating to to latest expo-cli, Facebook login no longer works.

How do I downgrade to previous expo-cli?

Code that worked before upgrade now generates this error…

E_FBLOGIN_APP_ID Tried to perform Facebook login, but no Facebook app id was provided. Specify Facebook app id in Info.plist. undefined undefined

undefined is not an object (evaluating ‘_ref.type’)

  • src/actions/user.js:82:11 in _callee3$
  • node_modules/@babel/runtime/node_modules/regenerator-runtime/runtime.js:45:44 in tryCatch
  • node_modules/@babel/runtime/node_modules/regenerator-runtime/runtime.js:271:30 in invoke
  • … 13 more stack frames from framework internals

See this thread: Facebook login promise rejection on iOS

Basically, you can upgrade your SDK to v36 and call Facebook.initializeAsync("", “”);

Thank you but there doesn’t seem to be a solution there.

oh. what do they mean by “bumping up to sdk 36”?

See the section at the very bottom that says Upgrading Your App

OMG Thank You! That was annoying. lost an entire day.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.