Facebook login crashes in standalone app


This was working in my app until two days ago. Suddenly it did not load the webview and crashes the standalone app.

It’s working in simulator though. No errors.

Anyone have any ideas?

1 Like

Hello @nur, are you testing on iOS 11 ?

yes it is on iOS 11. Previously it is also on iOS11.

Have you installed any (minor) system update recently?

Same here, IOS 11.2.2.

My app live in App store have started to receive:
“Error: Tried to perform Facebook login with behavior native, but no Facebook app id was provided. Specify Facebook app id in app.json or switch to web behavior.”

Was working last week and havent been updated since and had no behavior passed to logInWithReadPermissionsAsync().

Now all my tries to fix this I send to testFlight crashes silently on Facebook login.

I’m also having this issue. My first app store submission 3ish of days ago worked perfectly on ios. (despite my app.json not having the facebookScheme, facebookAppId, or facebookDisplayName entries…) My second submission failed a couple of days ago so I added those entries and added my Bundle ID in the facebook dev console as per the docs. I haven’t managed to get it working on a standalone in testflight since. Let me know if there’s any information you need that could help. Absolutely love the work you guys are doing.
(I’m using expo: 24.0.0)

I have restarted and moved all codes out of expo. It’s working now.

What do yo mean with:

Dont you use Expo anymore?

Have you had any success fixing this issue?

1 Like

Nope I’m afraid I haven’t.

https://github.com/expo/expo/issues/1327 -> looks like it might be resolved, please let us know if the issue is gone for you :slight_smile:

1 Like

Works fine now, thanks! :smile:

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.