Expo XDE Not Recognizing NPM update (Figured it out)

Brand new to Expo. When I created my first project right away I got an error that say:
Error: You are using npm version 5.0.3. Please use an npm version that is >= 3.0.0 and < 5.0.0. Run 'npm i -g npm@4.6.1' to resolve.

Now, I was running v5.0.3 so I downgraded globally to the recommended 4.6.1
sudo npm install npm@4.6.1 -g
now when I npm -v I get 4.6.1

I have refreshed, quitted, and tried clearing the expo cache and yet this error persists. How do I “fix” it further than globally updated Npm?

1 Like

As luck has it, I just needed to voice my complaint, and hit npm install 2 more times to get it to stick? Forgive the newbie question.

Sometimes npm etc are finicky. Glad you were able to wrangle it.