Expo Web CLI is broken ?

Hi,

I’ve tried this morning to initialize a expo web project and build it, but i’m facing this :

I’ve run these commands :

  • expo init (then fill my infos)
  • expo start
  • expo build:web

cd web-build && python -m SimpleHTTPServer 8000

also tried

http-server ./web-build

FYI, it does work on local with expo start. :confused:

Really sorry about this.

Deep scope analysis was rewritten and only the patch version was bumped. I suspect this could be what broke web builds.

Already pushed a fix https://github.com/expo/expo-cli/pull/796 it will hopefully be fixed in the next release.

With semver it’s common practice to allow any patch version in your dependency (which is what I did with deep scope). But this assumes that library authors don’t release breaking changes as patches but rather as major versions.

2 Likes

It’s totally fine :wink: we know it’s still in beta and that you’re actively working on it.
Thanks for your hard work. You’re just the GOAT :fist:

Will wait for the patch !

1 Like

@bacon How can i be notified when the fixes is released ?

I have disabled tree-shaking in this PR. I’ll be working on adding it back to as it drastically reduces the bundle size.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.