Expo/vector-icons not visible

SDK Version: 41
Platform: Android
expo/vector-icon version:12.0.4

Repo url -

I am using expo/vector-icons for getting icons in my react-native app. Earlier it was working fine suddenly it stopped working and showing an X (cross-sign) instead of an icon. Like this -

Solutions I have tried -

  1. deleting node_modules, .expo folder and reinstalled.
  2. updated expo go app to the latest version.
  3. tried different versions of expo/vector-icons
  4. tried running with the command “expo start -c” clearing the cache.
  5. tried on different emulators and physical devices, but not working anywhere.

I have read every article on google and tried everything but nothing seems to work, stucked for about 1 week. Please help!!

also share a How to create a Minimal, Reproducible Example - Help Center - Stack Overflow or a link to your repo

This is the repo URL -

But can’t create a reproducible example because I am not able to recognize the source of this issue. Otherwise, I would have solved it yet.

read the above links to learn how to create one! it’s a valuable skill to learn

I recreated the project on expo snack. It was asking me to add some peer dependencies and after that it ran on snack. But then again after installing the peer dependencies in my local pc, it didn’t worked.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.