Expo v2.10.0 30.0.0 not valid SDK on Android

I’m having an issue today running Android apps with Expo v2.10.0. On Android devices/simulators I am getting the following error message:

"Something went wrong.
30.0.0 is not a valid SDK
version. Options are 32.0.0,

Expo v2.9.2 does not display this error with the same project. We worked on the project as recently as last week with no issues.

IOS devices are not effected by the error.


1 Like

I don’t have a solution but have been fighting this issue all day as currently specifically developing on android via a simulator

Hey guys, sorry for the trouble! :disappointed:
The new version that contains a fix for that is now available on the Play Store. Please update your client to v2.10.1 :wink:

TY. All good now :wink:

I got the same error message and tried v2.10.1 from Play Store.
For me unfortunately v2.10.1 crashed after selecting the app or showed error after downloading the bundle showing 100%.
I tried with an official example and my on developing app on android device, both get the same result.

After hours, I found v2.9.2 apk file from 3rd party and downgrade to v2.9.2 which works.
(I didn’t find old versions from official website, if they are there please inform me.)

Post here for providing info to Expo Team and temporary downgrade solution for someone in need.

Thanks that has fixed my problem as well

Updating Expo didn’t solve the problem for me :disappointed:

Any ideas?

Hey @cgraio, is the client crashing or showing the error message that SDK version is not valid?
If it’s crashing, could you make sure that you have v2.10.2 installed?

It doesn’t crash, it shows the error message “25.0.0 is not a valid SDK version”. And yes, I have 2.10.2 installed.


@cgraio SDK25 is no longer supported, you need to update your app to the newer SDK.

Mmm ok, where can I see version support dates? Thanks.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.