expo upload:ios => SSL_connect failed

SDK 3.9.1
Platfrom IOS

Trying to publish to app store with
expo upload:ios --apple-id office@myemail.at --apple-id-password XXXXXXXX --sku com.someapp.name.ios

The Terminal respond
Available session is not valid any more. Continuing with normal login.

Failed to upload the standalone app to the app store.

SSL_connect returned=1 errno=0 state=error: certificate verify failed

Tried on 2 different macs Sierra and El capitan both with the same error OppenSLL 1.1 installed
Other SSL connection to github or account google worked .

Run the SSL test script from https://github.com/mislav/ssl-tools/blob/8b3dec4/doctor.rb all looks fine no error.


The SDK version will be shown in app.json. Something like 33.0.0 or 36.0.0. But that is not relevant to your problem.

The list of SSL CA certificates included with older versions of expo-cli was out of date, so you’ll need to upgrade to the latest version of expo-cli. Version 3.11.7 has the updated CA certificate bundle.

1 Like

Thank you wodin solved this problem
Just realise i need minimum Xcode 10 to upload so no siera or El capitain
or is there any publish to Apple store with expo without Xcode ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.