Expo suddenly stopped hot reloading.

Hello.
I am developing react-native app with expo.
It was excellent because when I changed my source and saves it. expo automatically updated UI components.
Yesterday, It worked well but now the hot reloading has been stopped.
So I have to reload the changes pressing reload button.
How can I solve this issue?
I asked expo developer and he introduced this forum site to me.
My develop environment is Windows 10 and I installed expo-client-app on my phone.
Can any one help me?
Thanks.

1 Like

Hey @social74,

Thanks for posting on our forums! I’m actually the one who responded to your email :slight_smile:

I just tried using hot reloading on my end, and it’s working well. When you bring up the Expo Menu while running your app in the Expo Client, does it say you have Hot Reloading enabled? (Note: you can’t have both Hot Reload and Live Reload enabled at the same time.)

Thanks for your answer, charliecruzan.
But where can I find expo menu?


This link shows expo menu. Right?
But I can’t bring up expo menu in my app.
Maybe I ever saw this menu before but I can’t correctly find it now.
I think when I pressed setting button on my device the menu had been shown.
Now it’s not showing.
How can I do it?
I use expo-client 2.10.6.

By default, I think you have to shake the device to bring up the menu. You can change that in the Settings to Two-Touch, though.

Even though I tried several ways to bring up the menu, it never appears.
The same issue on this link.

I am very sorry that I can’t solve this problem.
Maybe, I have to waste 2 seconds to refresh my app.
It’s all right. Instead of it, I will put a habit of making good code at once.
Anyway thanks, charliecruzan.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.