Expo Stuck in endless loop when starting from cli

Since updating to the latest SDK (following through the expo blog for upgrading) and updating the CLI to the latest version, whenever I try to start from CLI to a connected Android phone, I get the Expo app loading screen (the circle) forever.

I ran an adb logcat and it just logs a repeating:

Settings: Setting airplane_mode_on has moved from android.provider.Settings.System to android.provider.Settings.Global, returning read-only value.

I don’t believe that this is the cause of the issue, however it is the only error that seems to be logged anywhere.

Any ideas?


Hi garrrth-

Can you post a github link or a zip of your project?
It’s hard to figure out what’s going on without all your code.


Hi Charlie,

Thanks for taking the time.

repo is at: https://bitbucket.org/ebpomevents/events-mobile-app
branch: new_exp_sdk

Thanks heaps,

Ok @yarrington ran your project and there are two issues here:

  1. You have the .expo directory checked into your repo. There isn’t anything wrong with this necessarily, but it means that when exp or XDE tries to run your project it uses the localhost setting. This won’t work unless you are using the iOS simulator. Once I deleted the .expo directory and restarted exp it worked.
  2. We have a bug that triggers reloading when it can’t connect to the localhost server. I’ll fix this in the next release!

Hope that makes sense!

Ahhh, magic! That’s sorted it my end too.

.expo directory is actually in my .gitignore, so not sure why it’s gone up to the repository, but I’ve deleted it from my project and restarted and it’s worked a treat.

Thanks for the great support!!


1 Like

Great! Glad that worked. Going to push an android build that fixes the bug on our side later today.