`expo start` stuck, QR code not shown

I’m currently running an expo project in development mode. Whenever I run expo start or npm start in the terminal I get the following logs:

$ expo start                                                                                                                                                                      
Starting project at /Users/johncd/workspace
Expo DevTools is running at http://localhost:19002
Starting Metro Bundler on port 19001.
Tunnel ready.
Your native app is running at expb675c828acbb437095bc6218883f56bb://
Logs for your project will appear below. Press Ctrl+C to exit.

The expected results would include a QR code after these logs, but there is none.

When I visit the DevTools at localhost:90002 I see the metro bundler is running on LAN and a QR code is available. However, when I scan this QR code, it results in an error reading "No usable data found".

No usable data found when scanning QR code

  • I’ve tried checking for a Firewall (System preferences > Privacy > Firewall) but it appears to be turned off.

  • I have also tried uninstalling and re-installing expo-cli as well as the project and running expo start again but to no avail.

  • I’ve tried using npm start and yarn start. I have also tried running the project on a tunnel.

  • I created a test project using expo init test-project and successfully ran it using expo start, so it seems this issue is only occurring on this project.

  • I also tried running expo start --clear to clear the cache.

None of these have worked.

Any help is appreciated!

Expo diagnostics

  Expo CLI 3.1.0 environment info:
      OS: macOS High Sierra 10.13.6
      Shell: 5.3 - /bin/zsh
      Node: 10.16.0 - /usr/local/bin/node
      Yarn: 1.7.0 - /usr/local/bin/yarn
      npm: 6.11.3 - /usr/local/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
      Xcode: 10.1/10B61 - /usr/bin/xcodebuild
      expo: ^33.0.0 => 33.0.7 
      react: 16.8.3 => 16.8.3 
      react-native: https://github.com/expo/react-native/archive/sdk-33.0.0.tar.gz => 0.59.8 
      react-navigation: ^3.11.1 => 3.11.1 
      expo-cli: 3.1.0

1 Like

Hi. There are several things about your post that I find strange or unexpected.

I did not realise that there was a version of expo-cli later than 3.0.10, although it’s not terribly surprising, I suppose. I tried it out on my machine and it worked as expected in an existing project and also a newly created one. Differences: This was on Linux rather than macOS; The existing project was using SDK 34 and the newly created one SDK 35 rather than SDK 33; I was using node 12.x rather than node 10. I wouldn’t have expected any of these things to make it work for me while it doesn’t for you.

What happens if you press ‘c’ when Logs for your project will appear below. Press Ctrl+C to exit. is shown?

I don’t remember seeing something like the following before:

Your native app is running at expb675c828acbb437095bc6218883f56bb://

Also, the scheme for that URL is pretty weird. Maybe this is something to do with deep linking?

Did you scan the QR code using the Expo app or are you trying this on an iOS device?

What happens if you log in using expo-cli and also login to the app? You should see the running project under “Recently in development”.

Hi, I am not 100% sure if this was the cause, but I ran into this issue after I eject the project. (expo eject)

I don’t know enough about expo to confirm this, but it seemed to be what caused it with me.

1 Like

Yes, I agree. I just ejected a test app yesterday (to ExpoKit if that makes a difference) and got the above behaviour.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.