expo start - Request failed with status code 400

Getting the following error upon running expo start (before even building the bundle). I’ve already tried npm install -g expo -cli and reverting to an earlier version.

Expo Press ? to show a list of all available commands.
Logs for your project will appear below. Press Ctrl+C to exit.
Error: Request failed with status code 400
at createError (/Users/griffinkao/Desktop/anchor/frontend/node_modules/@expo/xdl/node_modules/axios/lib/core/createError.js:16:15)
at settle (/Users/griffinkao/Desktop/anchor/frontend/node_modules/@expo/xdl/node_modules/axios/lib/core/settle.js:17:12)
at IncomingMessage.handleStreamEnd (/Users/griffinkao/Desktop/anchor/frontend/node_modules/@expo/xdl/node_modules/axios/lib/adapters/http.js:237:11)
at IncomingMessage.emit (events.js:215:7)
at endReadableNT (_stream_readable.js:1183:12)
at processTicksAndRejections (internal/process/task_queues.js:80:21)

Current configuration

Expo CLI 3.11.7 environment info:
OS: macOS 10.14.6
Shell: 3.2.57 - /bin/bash
Node: 12.12.0 - /usr/local/bin/node
Yarn: 1.19.1 - /usr/local/bin/yarn
npm: 6.14.2 - /usr/local/bin/npm
Xcode: /undefined - /usr/bin/xcodebuild
@types/react: ~16.9.0 => 16.9.19
@types/react-native: ~0.60.23 => 0.60.31
expo: 36.0.0 => 36.0.0
react: ~16.9.0 => 16.9.0
react-native: https://github.com/expo/react-native/archive/sdk-36.0.0.tar.gz => 0.61.4
react-navigation: ^4.3.1 => 4.3.1
expo-cli: 3.18.0

I’m facing the same issue here. Anyone with a solution?

I see that you already tried updating expo-cli, but updating it worked for me.

‘npm install expo-cli -g’

Didn’t need to update anything and as of 9am CST Thursday, I can connect via tunnel to my local build.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.