Expo standalone apk stuck on splash screen

The app is running well on Expo Go both on dev and production mode with no errors. However, after building an android apk, the app is stuck on the splash screen. I have googled online for similar situations and none of the solutions has worked for me.

I have also tried to remove node_modules and run npm install but it has not worked out.

Here is my ‘expo diagonistics’
Expo CLI 4.11.0 environment info:
OS: Windows 10 10.0.19042
Node: 16.5.0 - C:\Program Files\nodejs\node.EXE
Yarn: 1.22.11 - C:\Users\harry\AppData\Roaming\npm\yarn.CMD
npm: 7.21.1 - C:\Program Files\nodejs\npm.CMD
Android Studio: Version AI-201.8743.12.41.7199119
expo: ~42.0.1 => 42.0.3
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-42.0.0.tar.gz => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
Expo Workflow: managed

I have retraced my steps and found out that this happened when I use Google.useAuthRequest() from the expo-auth-session package.

Using the deprecated expo-google-app-auth package works well and does not cause this issue.

Note: the issue occurs only when I build an apk and use it. On expo Go everything works fine while using either of the packages, there are no errors on dev and production mode.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.