Expo selecting wrong Apple Team Id while building

I am running expo build:ios for creating an archive build for the IOS store. The thing is there are a lot of teams in my apple dev account and while building the app the team id displayed under the Provisioning profile is of some other team that has no connection with the team I am working on - Dropbox - Screenshot 2020-11-09 at 5.13.10 PM.png - Simplify your life

I have tried revoking creds, creating certs, and profile manually but nothing is changed. Can someone please help me with this?

  Expo CLI 3.24.2 environment info:
      OS: macOS 10.15.7
      Shell: 5.7.1 - /bin/zsh
      Node: 12.16.3 - /usr/local/bin/node
      Yarn: 1.22.10 - /usr/local/bin/yarn
      npm: 6.14.4 - /usr/local/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
      Android Studio: 3.2 AI-181.5540.7.32.5056338
      Xcode: 11.6/11E708 - /usr/bin/xcodebuild
      expo: ^38.0.0 => 38.0.9
      react: 16.11.0 => 16.11.0
      react-dom: 16.11.0 => 16.11.0
      react-native: https://github.com/expo/react-native/archive/sdk-38.0.2.tar.gz => 0.62.2
      react-native-web: ~0.11.7 => 0.11.7
      expo-cli: 3.24.2

I have tried revoking creds, creating certs, and profile manually

Can you clarify what exact steps you did?

I don’t know exact details, so I can only provide a generic answer.

  • if you clear all credentials and select everywhere lets expo handle it everything should work correctly and if it doesn’t it’s a bug in expo-cli
  • if you provide credentials manually teamId for provisioning profile is read from provisioning profile and for the distribution certificate and push key it’s is provided by you in a prompt

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.