Expo SDK version is v.0.0.0 for the project which is published with eas update


 "dependencies": {
    "@expo/webpack-config": "^0.17.2",
    "@react-native-async-storage/async-storage": "~1.17.3",
    "@react-native-picker/picker": "^2.4.8",
    "@react-navigation/native": "^6.1.1",
    "@react-navigation/stack": "^6.3.10",
    "@reduxjs/toolkit": "^1.9.1",
    "body-parser": "^1.20.1",
    "eas-cli": "^3.7.0",
    "expo": "~47.0.9",
    "expo-auth-session": "~3.8.0",
    "expo-barcode-scanner": "~12.1.0",
    "expo-camera": "~13.1.0",
    "expo-cli": "^6.1.0",
    "expo-random": "~13.0.0",
    "expo-status-bar": "~1.4.2",
    "expo-updates": "~0.15.6",
    "express": "^4.18.2",
    "mongodb": "^4.13.0",
    "react": "18.1.0",
    "react-dom": "18.1.0",
    "react-native": "0.70.5",
    "react-native-dialog": "^9.3.0",
    "react-native-dropdown-picker": "^5.4.4",
    "react-native-paper": "^5.1.2",
    "react-native-safe-area-context": "4.4.1",
    "react-native-screens": "~3.18.0",
    "react-native-web": "~0.18.9",
    "react-native-webview": "11.23.1",
    "react-redux": "^8.0.5"
  "devDependencies": {
    "@babel/core": "^7.12.9"
  "private": true

Platforms : all

I know there are other similar questions and answers about this subject but none of them worked for me to solve this issue. I’m using npx eas update to publish my app on expo.

After update it gives me successful publish message:

:heavy_check_mark: Exported bundle(s)
√ Uploaded 2 app bundles
√ Uploading assets skipped - no new assets found
√ Channel: master pointed at branch: master
:heavy_check_mark: Published!

in my app.json, with other default tags I already added:

"runtimeVersion": {
  "policy": "sdkVersion"

I’ve tried to add

"runtimeVersion": "exposdk:47.0.0"

field to app.json and made

eas update:configure

to create eas.json as well.

In expo.dev the update seems to have right information too by mentioning

Runtime version exposdk:47.0.0.

But unfortunately when I want to open qr code of my project the screen that I have is this one by saying:

This project uses Expo SDK v0.0.0 If you want to open this project, the author will need to update the project's SDK version

enter image description here

Shortly the SDK version is not recognized and I can not change the privacy to public. I need to mention that updates in Expo Go app works fine on my IOS device and running well.

What could be the problem ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.