Expo SDK 34 + custom iOS = crash at splashscreen

After the update to SDK 34, the created ios custom client app does crash while starting.
The app was deinstalled and re-installed. Did restart the iPhone, too.
When opening the App the white Expo splash screen with the “A”-icon is visible for a second and then back to the home screen.

Device: iPhone XS with iOS 12.1
node: v12.7.0
npm: 6.11.2
yarn: 1.17.3
expo-cli: 3.0.10

Build link:


  "expo": {
    "name": "XXX-app",
    "description": "XXXX",
    "slug": "XXX-app",
    "privacy": "unlisted",
    "sdkVersion": "34.0.0",
    "version": "0.2.0",
    "orientation": "portrait",
    "icon": "./assets/app_1024_L.png",
    "splash": {
      "image": "./assets/splash_v2.jpg",
      "resizeMode": "contain",
      "backgroundColor": "#021b40"
    "packagerOpts": {
      "config": "metro.config.js",
      "sourceExts": [
    "updates": {
      "fallbackToCacheTimeout": 0
    "assetBundlePatterns": [
    "platforms": [
    "ios": {
      "bundleIdentifier": "XX.app",
      "config": {
        "usesNonExemptEncryption": false
    "android": {
      "package": "XX.app"

Expo diagnostics:

Expo CLI 3.0.10 environment info:
      OS: macOS 10.14.6
      Shell: 3.2.57 - /bin/bash
      Node: 12.7.0 - ~/.nvm/versions/node/v12.7.0/bin/node
      Yarn: 1.17.3 - ~/.yarn/bin/yarn
      npm: 6.11.2 - ~/.nvm/versions/node/v12.7.0/bin/npm
      Xcode: 10.2.1/10E1001 - /usr/bin/xcodebuild
      expo-cli: 3.0.10

I have encountered the same problem.

Device: iPhone XS with iOS 12.4.1

Then I suspect the problem is on the Profile file.So I cleared Certificates & Identifiers & Profiles on the apple developer account and use expo client:ios rebuild it for many many time. Undoubtedly failed. Just crash and crash
When the Profile been installed, it just open a web page, but it didn’t show up at configuration profile like other Profile file
And I tried it with Apple configurator 2. the same
I very much hope that someone can come out and help us solve this problem.
Thank you very much


Same here. Been happening for weeks now definitely set my project back, and I’m sure lots of people are experiencing this issue.


If you look at that GitHub issue, it sounds like the custom iOS client is totally broken. I, for one, can no longer get it to work. Is anyone able to?

Our team is facing the same issue, the custom iOS Client crashed. We have tried on multiple devices whose UDID is registered with the provisioning profile created by expo.

Our expo version is 34.0.1 .
We have tried on expo cli versions 3.0.10 and 3.0.11-alpha.1

It has been fixed in the recent version. See https://github.com/expo/expo/issues/5537#event-2700764947

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.