Expo sdk 33 build fails at the splash Screen with Uncaught Error:Application main has not been registered

Getting the following error log when trying to run the apk created with expo build:android, have been stuck for a week please help.

Hey @crystalwarrior,

This could be the result of you building your binary while we temporarily had custom builds enabled and thus the unimodules package was not installed as it would normally be. Could you try updating your expo-cli version if it isn’t already updated and then building a new binary?


@adamjnav I had updated expo-cli today and tried the build again but still got the same error. What does unimodule mean can you help with that if could add it manually ?

I just updated to 33 and getting same thing when building/running an APK. CLI version was 2.20.1 and build completed an hour ago. I tried running expo start --no-dev --minify and can not reproduce. I also updated babel-preset-expo to latest and republished. I will try to rebuild the APK now as suggested.

I commented out all my FaceDetector references after reading this github issue:

After republishing, my APK runs now. Separate issue but maybe related, I also noticed a lot of stuttering and dropped frames when running in the client after upgrading to 33. Wonder if that is also related to FaceDetector. Will check if it is improved tomorrow.

1 Like

Thanks mate. @mkuritz I too got it working when commented out the facedetector references

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.