expo push:android:upload --api-key FAILED

  1. SDK Version: 39
  2. Platforms(Android/iOS)

Hi @charliecruzan @adamjnav
today i have updated my app from SDK 38 to SDK 39
and i tried to send push notification to my app
but i didn’t get it
although earlier (on SDK 38) everything worked

after that i did this expo push:android:upload --api-key
and got this error
An unknown error occurred.

1 Like

Same problem on SDK38.
I tried to update my key and unfortunately this error came up, even though week ago it worked.

1 Like

Same here.

hi all, we’ve tracked this issue down in the server and have applied a fix. Please let me know if you are still experiencing this problem

Today this command works good
but notifications doesnt work

      "id": "1c3d887b-7ce8-4208-8637-a04063d4c42f",
      "status": "error",
      "message": "The recipient device is not registered with FCM.",
      "details": {
        "error": "DeviceNotRegistered",
        "fault": "developer"

hey @alexhodovas – we’ve sent off the push notifications to the FCM endpoint and received a NotRegistered error. In the docs here, it should give you some steps to remedy (its the 3rd row). But the root cause is that the client app has unregistered with FCM (can happen for a variety of reasons, like the user uninstalling the app)

Same issue here. expo push:android:upload --api-key doesn’t work after upgrading to SDK39
It was working before.

I tried these commands:

expo push:android:show
expo push:android:clear

And they are working fine. But I can’t upload a new key

@ucha4964 what is the error message you are getting?

Exactly the same error as the original post author had.

hey @ucha4964 i tracked down your error in the server logs and am working on a fix. We are aiming to deploy it by early next week. thanks for your patience!

1 Like

@ucha4964 the fix should be deployed now, pls lmk if you still encounter the same problem. thx!